BGP Configurations on HP Routers

Today I am going to talk about the BGP configurations on the HP routers. I already posted the articles on the BGP configurations earlier where i defined the basic configurations on the Cisco and Juniper routers. Apart from these configurations I already put the basic information of the BGP as well.

Today I am going to have the basic configurations on HP routers with the topology. Below is the basic topology and the basic BGP configuration as below. The Topology and the IP addresses used here are only for the demo purposes and has no relevance with any of the live or enterprise networks.

Below is the demo topology showing the use of the HP routers where BGP is configured in the MPLS environment. This is just a example to showcase the topology. I will come up with the configurations on HP routers in the MPLS environment in later stage. As of now first we need to talk about the basic BGP on the HP routers and step by step we will discuss the configurational part in the MPLS environment as well.

Fig 1.1- Demo BGP topology in MPLS environment

As of now we will going to discuss BGP basics configuration on HP routers with the configurations.

Here in our example, the basic BGP connectivity with a Layer 3 provider over a single link. The provider’s BGP AS is 65000. The customer AS is 65001. BGP allows all sites to know when other sites are available. 

The site has assigned each remote site a /24 prefix from 10.10.x.0, where x represents the site number. In this example, the site number is 1. At each site, the /24 prefix is variably subnetted on local LANs. Only the /24 prefix is advertised to the provider network for propagation to other sites. The provider delivers each customer /24 prefix to the other sites. 


Fig 1.1- Basic BGP Topology
Below is the basic configurations on the HP routers for the above mentioned topology.

!
hostname "Site 1"
!
ip routing
!
interface loop 1
   description Management Interface
ip address  10.10.1.254  255.255.255.255
no shutdown 
!
interface eth 0/1
description Local LAN
ip address 10.10.1.193 255.255.255.224 
no shutdown 
interface t1 1/1
  description NtwkT1 CktID 54321
  tdm-group 1 timeslots 1-24 speed 64
  no shutdown
!
interface fr 1 point-to-point
description WANFR CktID 67890 frame-relay lmi-type ansi
no shutdown
bind 1 t1 1/1 1 frame-relay 1 
!
interface fr 1.17 point-to-point
  description PVC17
  frame-relay interface-dlci 17
  frame-relay bc 768000
  description Frame Relay 1.17 DLCI-17
  ip address  64.19.120.2 255.255.255.252
  bandwidth 768
!
router bgp 65001 
  no auto-summary
  no synchronization
  bgp router-id 10.10.1.254
  network 10.10.1.0 mask 255.255.255.0
  neighbor 64.19.120.3
no default-originate
description BGP AS-65001 Peer-65000 
    soft-reconfiguration inbound
    update-source loop 1
    remote-as 65000
!
!
ip route 10.10.1.0 255.255.255.0 null 0
!
no ip http server
no ip http secure-server
!
ip ftp source-interface loopback 1 
ip radius source-interface loopback 1
ip tftp source-interface loopback 1
ip sntp source-interface loopback 1
logging forwarding source-interface loopback 1
!
line con 0
  no login
  line-timeout 60
!
line telnet 0 4
  login
  line-timeout 60
!

end 
!

It is the basic BGP configurations as per the topology shown above.