Cisco Nexus 9372 FCoE Configuration Example
Today I am going to talk about the configuration example of Cisco Nexus 9K FCoE configuration. Now the question is what is FCoE. Fibre Channel over Ethernet (FCoE) is a computer network technology that encapsulates Fibre Channel frames over Ethernet networks. With the help of this FCoE can use the 10G ethernet channels.
First of all Let me tell you which models support FCoE in Nexus 9K. Below are the models which are supported one.
First of all Let me tell you which models support FCoE in Nexus 9K. Below are the models which are supported one.
![]() |
Fig 1.1- Sample Topology for FCoE |
Nexus 9K Switch Models that support NPV FCoE ONLY:
- N9K-C9396PX
- N9K-C9372PX
- N9K-C9372PX-E
- N9K-C9332PQ
- N9K-93180YC-EX
- N9K-93108TC-EX
Nexus 9K GEM modules that support NPV FCoE:
- N9K-M12PQ
- N9K-M12PQ2
- N9K-M6PQ
- N9K-M6PQ-E
What will be the Limitations of FCoE NPV ?
- Supported only on Standalone N9Ks
- Not supported with FEX ports
Configuration on Nexus 9372 which has NX-OS has below FCoE configuration
!
switchname N9372-1
class-map type network-qos c-default
policy-map type network-qos fcoe_nq
class type network-qos c-nq3
pause pfc-cos 3
mtu 9216
class type network-qos c-nq2
mtu 9216
class type network-qos c-nq1
mtu 9216
class type network-qos c-nq-default
mtu 9216
install feature-set fcoe-npv
!
vdc N9372-1 id 1
allow feature-set fcoe-npv
!
feature-set fcoe-npv
feature lldp
!
class-map type qos match-any fcoe
match protocol fcoe
match cos 3
policy-map type qos fcoe
class fcoe
set qos-group 3
class class-default
set qos-group 0
policy-map type queuing fcoe-in-policy
class type queuing c-in-q3
bandwidth percent 50
class type queuing c-in-q-default
bandwidth percent 50
policy-map type queuing fcoe-out-policy
class type queuing c-out-q3
bandwidth percent 50
class type queuing c-out-q-default
bandwidth percent 10
class type queuing c-out-q1
bandwidth percent 10
class type queuing c-out-q2
bandwidth percent 30
system qos
service-policy type queuing input fcoe-in-policy
service-policy type queuing output fcoe-out-policy
service-policy type network-qos fcoe_nq
copp profile strict
!
vlan 2000
fcoe vsan 2000
!
vsan database
vsan 2000
!
feature npiv
!
vsan database
vsan 2000 interface vfc2000
vsan 2000 interface vfc2100
!
interface vfc2000
description QLE8362 attached host
bind interface Ethernet1/48
switchport trunk allowed vsan 2000
switchport trunk mode on
no shutdown
!
interface vfc2100
description Uplink to core NPIV switch MDS 9250i
bind interface Ethernet1/49
switchport mode NP
switchport trunk mode on
no shutdown
!
interface Ethernet1/48
switchport mode trunk
switchport trunk allowed vlan 2000
mtu 9216
service-policy type qos input fcoe
!
interface Ethernet1/49
switchport mode trunk
switchport trunk allowed vlan 2000
speed-group 10000
mtu 9216
service-policy type qos input fcoe
!
Show commands:
- show npv status
- show npv flogi-table
- show tech-support npv
- show npv internal event-history msgs
- show npv internal event-history svr-if-fsm [ interface < interface > ]
- show npv internal info
- show npv internal info external-interface { all | < interface > }
- show npv internal info global
- show npv internal info interface { all | < interface > }
- show npv internal info server-interface { all | < interface > }
- show npv internal mem-stats [ detail ]
- show npv internal pending-queue interface { all | < interface >
Debug Commands:
- debug npv trace
- debug npv errror
- debug npv warning
- debug fcoemgr trace
- debug fcoemgr error
- debug fcoemgr warning