Cisco Datacenter: Introduction to FCOE, FEX and FCoE over FEX

Today I am going to talk about datacenter topic where I am going to discuss about the configuration example of FCoE over FEX. You may know these datacenter terms, if not let me take through it. FCoE stands for Fiber Channel over Ethernet and FEX stands for Fabric Extender. 

What is FCoE?
FCoE stands for Fibre Channel over Ethernet and is a protocol that permit Fibre Channel communications to route straight over Ethernet. FCoE builds it achievable to move Fibre Channel traffic throughout current high-speed Ethernet infrastructure and meets storage and IP protocols onto a single cable transport and interface.

What is FEX?
As Discussed, FEX stands for Fabric Extender (FEX) and it is technology which brings an extensible and a scalable fabric that delivers a flexible and wide-ranging solution as part of Cisco Unified Fabric. FEX is not a switch, it is just like an interface module for the extension of the server connectivity in Switched datacenter network. FEX is connected with the Nexus devices like Nexus 5k or Nexus 7K to save the ports on the Access layer or distribution layer.

FCoE over FEX
The Fibre Channel over Ethernet (FCoE) over Fabric Extenders (FEX) feature lets Fibre Channel traffic to be transported on a FEX port. Here in our example the FEX is attached to a Cisco Nexus 9K device that is in FCoE NPV mode through a Fabric Port Channel (FPC). FCoE over FEX permits the provisioning of FCoE on host connections.

FCoE over FEX with virtual Port Channel (vPC) permits Fibre Channel traffic to be transported throughout a FEX by means of a virtual Port Channel (vPC).LAN shutdown feature senses the ability of the FCoE host to provision Data Center Bridging (DCBX). 

DCBX permits the switch to transport the LLS messages in a type-length-value (TLV) format. The LAN shutdown feature allows bring up and bring down of LAN links on a unified link transport both FCoE and LAN traffic. When you use the shutdown LAN command, only the LAN traffic stops while the FCoE traffic continues.

FCoE over FEX topologies
We have three different kinds of topologies for FCoE over FEX and these topologies are Straight through FEX with Host Topology, straight through FEX with Host FEX vPC topology and Dual homed FEX topology showing below in the diagram.

Fig 1.1- FCoE over FEX topologies
CASE1: Configuration for Straight through FEX with Host Topology
!
install feature-set fex
feature-set fex
!
fex 101
  pinning max-links 1
  description "2232PP-1"
!
interface port-channel101
  switchport
  switchport mode fex-fabric
  fex associate 101
  mtu 9216
!
interface Ethernet1/1
  switchport
  switchport mode fex-fabric
  fex associate 101
  mtu 9216
  channel-group 101
  no shutdown
!
interface Ethernet101/1/1
  switchport mode trunk
  service-policy type qos input fcoe-qo-policy
  no shutdown
!

CASE-2: Configuration for Straight through FEX with Host FEX vPC topology

!
install feature-set fex
feature-set fex
!
fex 101
  pinning max-links 1
  description "2232PP-1"
!
interface port-channel101
  switchport mode fex-fabric
  fex associate 101
!
interface port-channel101
  switchport
  switchport mode fex-fabric
  fex associate 101
  mtu 9216
!
interface Ethernet1/1
  switchport
  switchport mode fex-fabric
  fex associate 101
  mtu 9216
  channel-group 101
  no shutdown
!
interface Ethernet101/1/1
  switchport mode trunk
  channel-group 1
  no shutdown
!
interface port-channel1
  switchport
  switchport mode trunk
  service-policy type qos input fcoe
  vpc 3
!
interface vfc-po1        
bind interface port-channel1
switchport trunk mode on
no shutdown
!
interface vfc101/1/1   
  bind interface ethernet101/1/1
  switchport trunk mode on
  no shutdown
!

Configuration on Peer-2
!
install feature-set fex
feature-set fex
!
fex 102
  pinning max-links 1
  description "2348UPQ-2"
!
interface port-channel102
  switchport
  switchport mode fex-fabric
  fex associate 102
  mtu 9216
!
interface Ethernet102/1/1
  switchport mode trunk
  channel-group 1
  no shutdown
!
interface port-channel1
  switchport
  switchport mode trunk
  service-policy type qos input fcoe
  vpc 3
!
interface vfc1   
  bind interface port-channel1
  switchport trunk mode on
  no shutdown
!
interface vfc2   
  bind interface ethernet102/1/1
  switchport trunk mode on
  no shutdown
!

CASE-3 Dual homed FEX topology
Peer-1
!
fex 170
  pinning max-links 1
  description "2232PP-3 AA"
  fcoe
!
interface port-channel170
  switchport
  switchport mode fex-fabric
  fex associate 170
  mtu 9216
  vpc 1
!
interface Ethernet170/1/18
  switchport mode trunk
  service-policy type qos input fcoe-qo-policy
  no shutdown
!
interface vfc1718     
  bind interface Ethernet170/1/18
  switchport trunk mode on
  no shutdown
!
interface vfc170/1/18 
  bind interface Ethernet170/1/18
  switchport trunk mode on
  no shutdown
!

Peer 2
!
fex 170
  pinning max-links 1
  description "2232PP-3 AA"
  !
interface port-channel170
  switchport
  switchport mode fex-fabric
  fex associate 170
  mtu 9216
  vpc 1
!
interface Ethernet170/1/18
  switchport mode trunk
  service-policy type qos input fcoe-qo-policy
  no shutdown
!