Juniper Routers Sample BGP Configurations : Quick and Easy

As in my earlier post i wrote about the basic configurations on Cisco Router where i define configurations on Route Reflector, Confederation, Route-Maps, Prefix Lists, Local Preference, AS-Path, MED, Communities and Peer groups.

In this article I am just going to put Juniper router basics BGP configurations. In the later articles I will cover all the configurations like Route Reflector, Confederation, Route-Maps, Prefix Lists, Local Preference, AS-Path, MED, Communities and Peer groups on juniper and Huawei routers.

Below is the basic network topology with configuration as below

Fig 1.1- Juniper Router BGP Topology
Here in the above shown topology, we have Router A, Router B, Router C, Router D and Router E. Router A, B and C are in the AS 22 while Router D is in AS 79 and Router E is in AS 17

Configure the interfaces to Peers A, B, C, and D
Router_NB# set ge-1/2/0 unit 0 description to-A
Router_NB# set ge-1/2/0 unit 0 family inet address 10.10.10.1/30
Router_NB# set ge-0/0/1 unit 5 description to-B
Router_NB# set ge-0/0/1 unit 5 family inet address 10.10.10.5/30
Router_NB# set ge-0/1/0 unit 9 description to-C
Router_NB# set ge-0/1/0 unit 9 family inet address 10.10.10.9/30
Router_NB# set ge-1/2/1 unit 21 description to-D
Router_NB# set ge-1/2/1 unit 21 family inet address 10.21.7.1/30

Set the autonomous system (AS) number
Router_NB# set autonomous-system 17

Create the BGP group, and add the external neighbor addresses
Router_NB# set neighbor 10.10.10.2
Router_NB# set neighbor 10.10.10.6
Router_NB# set neighbor 10.10.10.10

Specify the autonomous system (AS) number of the external AS
Router_NB# set peer-as 22

Add Peer D, and set the AS number at the individual neighbor level
Router_NB# set neighbor 10.21.7.2 peer-as 79

Set the peer type to external BGP (EBGP)

Router_NB# set type external

Show configurations

Router_NB# show interfaces
ge-1/2/0 {
unit 0 {
description to-A;
family inet {
address 10.10.10.1/30;
}
}
}
ge-0/0/1 {
unit 5 {
description to-B;
family inet {
address 10.10.10.5/30;
}
}
}
ge-0/1/0 {
unit 9 {
description to-C;
family inet {
address 10.10.10.9/30;
}
}
}
ge-1/2/1 {
unit 21 {
description to-D;
family inet {
address 10.21.7.1/30;
}
}
}