Configurations : Cisco Nexus vPC and Arista MLAG

Today I am going to talk about the technologies used for the port channel in the datacenter environment by Cisco and Arista Networks. Many of you guys already knew about vPC and MLAG and some of you may be understand the vPC technology but not aware of MLAG term used by Arista Networks in their environment.

Arista Networks MLAG:
Talking about Arista MLAG first, Arista’s MultiChassis Link Aggregation (MLAG) feature removes this bottleneck and allows the utilization of all interconnects in an active/active mode. In order to utilize all interconnects in an active/active manner, Arista EOS now supports the MLAG feature. This allows one to interconnect two Arista 7000 Family switches and use them as one logical switch for the purpose of L2 protocols such as STP or LACP.

Below is the sample topology showing the MLAG use in the Arista Network ( Datacenter environment). Hope the below mentioned network topology helps to understand about the MLAG.

Fig 1.1- Arista Networks MLAG and LAG 

Features of using MLAG in the datacenter environment
  • Up to 16 1GbE or 10GbE ports can be aggregated together and spread across the two switches
  • Two Arista 7000 Family network switches can be in an MLAG pair, increasing your network scalability by 2X
  • Allows you to design non-blocking networks
  • Maintains same level of resiliency with redundant paths available at all times
  • No proprietary protocol used to connect an MLAG pair to servers or other switches. Interconnect to other switches or servers can use static LAG or IEEE 802.3ad LACP
  • Spanning Tree Protocol can still be used in conjunction with MLAG to detect and handle any misconfigurations
  • No wasted bandwidth with uplinks in Spanning Tree Blocking state
Lets talk about the basic configurations on these switches ( Sample Configurations)


Configuration on Arista Switch 1
!
vlan 4094
   trunk group MLAG_Peer
!
interface Vlan4094
   ip address 172.17.255.1/30
!
mlag configuration
   domain-id MLAG1
   local-interface Vlan4094
   peer-address 172.17.255.2
   peer-link Port-Channel1
!
interface Port-Channel1
   switchport mode trunk
   switchport trunk group MLAG_Peer
!
interface Ethernet47
   channel-group 1 mode active
!
interface Ethernet48
   channel-group 1 mode active
!
interface Port-Channel200
   switchport mode trunk
   mlag 200
!
interface Ethernet10
  switchport mode trunk
  channel-group 200 mode active
!

The port-channle and the IP addresses uses in the above mentioned configuration is just for the sample configuration and has no relevance with any of the enterprise network.

Configuration on Arista Switch 2
!
vlan 4094
   trunk group MLAG_Peer
!
interface Vlan4094
   ip address 172.17.255.2/30
!
mlag configuration
   domain-id MLAG1
   local-interface Vlan4094
   peer-address 172.17.255.1
   peer-link Port-Channel1
!
interface Port-Channel1
   switchport mode trunk
   switchport trunk group MLAG_Peer
!
interface Ethernet47
   channel-group 1 mode active
!
interface Ethernet48
   channel-group 1 mode active
!
interface Port-Channel200
   switchport mode trunk
   mlag 200
!
interface Ethernet10
  switchport mode trunk
  channel-group 200 mode active
!

Now let's talk about Cisco vPC in the datacenter environment 

Cisco Nexus vPC:
As in my earlier articles i wrote about the basics of the Cisco Nexus vPC in the datacenter environment and you can go through the below mentioned link for the reference to get some of the information

vPC stands for Virtual Port Channel and is a virtualized technology, So it allows links that are physically connected to two different Cisco Nexus 7000 Series devices to appear as a single port channel to a third device. 

Fig 1.2- Cisco Nexus vPC

The third device can be a switch, server, or any other networking device that supports link aggregation technology. 
  • It actually eliminates Spanning Tree Protocol blocked ports
  • with the help of vPC, you can use all the uplink available bandwidths
  • Allows dual homed servers to operate in active-active mode
  • Providing Fast convergence on link failures
  • Providing dual active default gateways for servers
  • Simplify your network design and build high resilient and robust Layer 2 Network.
  • Excellent Scalability and seamless virtual machine mobility.

Let me talk about the basic configurations for Cisco Nexus vPC on the switches 

Cisco Nexus Switch 1:
!
interface mgmt0
vrf member management
ip address 192.168.1.7/25
!
feature vpc
!
vpc domain 11
peer-switch
role priority 1
peer-keepalive destination 192.168.1.8
delay restore 60
peer-gateway
!
interface port-channel1
switchport mode trunk
spanning-tree port type network
vpc peer-link
!
interface Ethernet2/1
switchport mode trunk
channel-group 1 mode active
!
interface Ethernet2/2
switchport mode trunk
channel-group 1 mode active
!
interface port-channel200
switchport mode trunk
vpc 200
!
interface Ethernet1/27
switchport mode trunk
channel-group 200 mode active
!

Cisco Nexus Switch 2:
!
interface mgmt0
vrf member management
ip address 192.168.1.8/25
!
feature vpc
!
vpc domain 11
peer-switch
role priority 1
peer-keepalive destination 192.168.1.7
delay restore 60
peer-gateway
!
interface port-channel1
switchport mode trunk
spanning-tree port type network
vpc peer-link
!
interface Ethernet2/1
switchport mode trunk
channel-group 1 mode active
!
interface Ethernet2/2
switchport mode trunk
channel-group 1 mode active
!
interface port-channel200
switchport mode trunk
vpc 200
!
interface Ethernet1/27
switchport mode trunk
channel-group 200 mode active
!