Cisco Router as Terminal Server- Why and how to configure

Today I am going to talk about the Cisco Router as a Terminal server in the datacenter environment. So the question is why and where we are going to use the terminal server?

Let's talk about the Terminal server what exactly is and why we are using the Terminal server in the datacenter environment.

Terminal Server:
A terminal server commonly provides out-of-band access for multiple devices. A terminal server is a router with multiple, low speed, asynchronous ports that are connected to other serial devices, for example, modems or console ports on routers or switches.

Fig 1.1- Cisco Router as Terminal Server

A terminal server works via a reverse telnet operation. Next, connect the asynchronous octal cable(s) to the 2511's 68-pin SCSI interface(s). Then connect a rolled console cable from the COM1 port (serial) on your PC to the console port on the terminal server. Power the device on and use a terminal emulator such as HyperTerm to connect.

The terminal server allows you to use a single point to access the console ports of many devices. A terminal server eliminates the need to configure backup scenarios like modems on auxiliary ports for every device. You can also configure a single modem on the auxiliary port of the terminal server, to provide dial-up service to the other devices when network connectivity fails.


Note: The async ports from the 68-pin connector are data terminal equipment (DTE) devices. DTE to DTE devices require a rolled (null modem) cable and DTE to data circuit-terminating equipment (DCE) devices require a straight-through cable. The CAB-OCTAL-ASYNC cable is rolled. Therefore, you can connect each cable directly to the console ports of devices with RJ-45 interfaces. However, if the console port of the device to which you connect is a 25-pin interface (DCE), you must use the RJ-45 to 25-pin adapter marked "Modem" (to reverse the "roll") in order to complete the connection. Set up your terminal settings as follows:

  • 9600 bps
  • 8 data bits
  • 0 parity bits
  • 1 stop bit
  • No flow control
You can connect number of devices and your router will act as Terminal Server as shown in the above diagram. Make sure the port is Async Port on the router and the SCSI 68-pin connector is used for the terminal sockets. Hope the above diagram clears the concept of the terminal server.

Now we have the configs for the Terminal Server as follows:-

Router>enable
Router#configure terminal
Router(config)#hostname ttlbits
ttlbits(config)#enable password donna
ttlbits(config)#line vty 0 4
ttlbits(config-line)#login
ttlbits(config-line)#password donna
ttlbits(config-line)#logging synchronous
ttlbits(config-line)#exec-timeout 30
ttlbits(config-line)#exit
ttlbits(config)#interface loopback 0
ttlbits(config-if)#ip address 1.1.1.1 255.0.0.0
ttlbits(config-if)#no shut
ttlbits(config-if)#exit
ttlbits(config)#ip host r1 2001 1.1.1.1
ttlbits(config)#ip host r2 2002 1.1.1.1
ttlbits(config)#ip host r3 2003 1.1.1.1
ttlbits(config)#ip host r4 2004 1.1.1.1
ttlbits(config)#ip host r5 2005 1.1.1.1
ttlbits(config)#line 1 16
ttlbits(config-line)#transport input ?
ttlbits(config-line)#transport input all
ttlbits(config-line)#no exec

Now Save the Configs for the Terminal Server. Terminal Server running-config is as shown as follows:-

ttlbits#show running-config
hostname 
ttlbits
enable password donna
ip host r1 2001 1.1.1.1
ip host r2 2002 1.1.1.1
ip host r3 2003 1.1.1.1
ip host r4 2004 1.1.1.1
ip host r5 2005 1.1.1.1
interface Loopback0
 ip address 1.1.1.1 255.0.0.0
line con 0
 transport input none
line 1 16
 transport input all
 no exec
line aux 0
line vty 0 4
 password donna
 exec-timeout 30 0
 password donna
 logging synchronous
 login
end

Let's look what all Command actually means : A Summary

ip host: This command is used to define the name-to-address mapping of the static host in the host cache. in order to remove the name-to-address mapping, use the no form of this command.
name: This field indicates the name of the host. The name field need not match the actual name of the router to which you want to connect. However, ensure that you enter a name you would want to use in the reverse Telnet. When you use this command and the name field, you do not have to know the actual port number of the remote device.
tcp-port-number:This field represents the TCP port number to which you want to connect when you use the defined host name along with an EXEC connect or telnet command. In our example configuration, we use a reverse Telnet so the port number must be 2000+line number.
address1: this field represents an associated IP address. In our example configuration, we use the loopback IP address.
port: This field indicates a decimal TCP port number. The Telnet router port (decimal 23) on the host is the default decimal TCP port number. For reverse Telnet, the port number must be 2000+line number. Line numbers range from 1-16 in our configuration. Use the show line EXEC command to view the available lines.