Articles
recent

Huawei Switches: Configuring VRRP in Master/Backup Mode

Today I am going to talk about the configuration example of VRRP in Master/Backup mode on to the Huawei switches. Before I started with the VRRP configuration, i guess people should aware of VRRP protocol in detail. VRRP stands for Virtual Router Redundancy Protocol. I wrote an article on VRRP earlier and if you want to have a look on the that article, you can go through the below mentioned link as a reference 

VRRP: Virtual Router Redundancy Protocol

Today I am going to talk about the configuration example of VRRP on Huawei routers with topology. Hope you got the basic understanding on VRRP protocol as of now from the above mentioned link.

Fig 1.1- VRRP Topology
From the above topology, we have :

The VRRP group that consists of Switches ( RouteXP_Master and RouteXP_Backup) will act as a default gateway for Host A.As a master Switch RouteXP_Master act as a gateway and if it fails then RouteXP_Backup will be the gateway.Let us suppose if Switch RouteXP_Master will came back or recovers then it will preempts to be the master within 20 seconds.

As you already knew the functions of VRRP protocol, lets talk about the configuration of the VRRP on Huawei devices. The IP addresses uses here for the above topology has no relevance with any of the enterprise network and used for only demo purposes.

Configuration on Switch RouteXP_Master:

First of all we need to create VLANs and then assign interface to that VLAN

RouteXP_Master# vlan batch 100 200
RouteXP_Master# interface GE0/0/1
RouteXP_Master-GE0/0/1# port hybrid pvid vlan 100
RouteXP_Master-GE0/0/1# port hybrid untagged vlan 100
RouteXP_Master-GE0/0/1# quit

Now Configure IP address to VLAN interface

RouteXP_Master# interface vlanif 100
RouteXP_Master-vlanif100# ip address 10.1.1.1 24
RouteXP_Master-vlanif100# quit
RouteXP_Master# interface vlanif 200
RouteXP_Master-vlanif200# ip address 192.168.1.1 24
RouteXP_Master-vlanif200# quit
RouteXP_Master#

Now configuring RouteXP_Backup and Switch C

Switch RouteXP_Backup
RouteXP_Backup# interface vlanif 100
RouteXP_Backup-vlanif100# ip address 10.1.1.2 24
RouteXP_Backup-vlanif100# quit
RouteXP_Backup# interface vlanif 400
RouteXP_Backup-vlanif400# ip address 192.168.2.1 24
RouteXP_Backup-vlanif400# quit

Switch C
Switch C# interface vlanif 200
Switch C-vlanif200# ip address 192.168.1.2 24
Switch C-vlanif200# quit
Switch C# interface vlanif 300
Switch C-vlanif300# ip address 20.1.1.1 24
Switch C-vlanif300# quit
Switch C# interface vlanif 400
Switch C-vlanif400# ip address 192.168.2.2 24
Switch C-vlanif400# quit

Now Configure OSPF protocol between these switches

RouteXP_Master# ospf 1
RouteXP_Master-ospf-1# area 0
RouteXP_Master-ospf-1-area-0.0.0.0# network 10.1.1.0 0.0.0.255
RouteXP_Master-ospf-1-area-0.0.0.0# network 192.168.1.0 0.0.0.255
RouteXP_Master-ospf-1-area-0.0.0.0#quit
RouteXP_Master-ospf-1#quit
RouteXP_Master#

RouteXP_Backup# ospf 1
RouteXP_Backup-ospf-1# area 0
RouteXP_Backup-ospf-1-area-0.0.0.0# network 10.1.1.0 0.0.0.255
RouteXP_Backup-ospf-1-area-0.0.0.0# network 192.168.2.0 0.0.0.255
RouteXP_Backup-ospf-1-area-0.0.0.0#quit
RouteXP_Backup-ospf-1#quit
RouteXP_Backup#

SwitchC# ospf 1
SwitchC-ospf-1# area 0
SwitchC-ospf-1-area-0.0.0.0# network 10.1.1.0 0.0.0.255
SwitchC-ospf-1-area-0.0.0.0# network 192.168.2.0 0.0.0.255
SwitchC-ospf-1-area-0.0.0.0# network 20.1.1.0 0.0.0.255
SwitchC-ospf-1-area-0.0.0.0#quit
SwitchC-ospf-1#quit
RouteXP_Backup#

Configuring VRRP group on Master and Backup Switch

Master Switch
RouteXP_Master# interface vlanif 100
RouteXP_Master-vlanif100# vrrp vrid 1 virtual-ip 10.1.1.111
RouterXP_Master-vlanif100# vrrp vrid 1 priority 120
RouterXP_Master-vlanif100#vrrp vrid 1 preempt-mode timer delay 20
RouterXP_Master-vlanif100#quit

Backup Switch
RouteXP_Backup#interface vlanif 100 
RouteXP_Backup-vlanif100# vrrp vrid 1 virtual-ip 10.1.1.111
RouterXP_Master-vlanif100#quit

Popular Posts

Powered by Blogger.