Articles
recent

Configuration OSPF To Filter Type-5 LSAs

Today I am going to talk about OSPF protocol where we will discuss on the filtering of the type-5 LSAs from the network. These type 5 LSAs are external LSAs which are originated by ASBR router and can be learned from external OSPF or another routing protocol like EIGRP, RIP or BGP.

Here today I am going to talk about the LSA 5learning from the external network and we are using EIGRP for this case.

Before I start with the configuration and the topology discussion, I would like you guys to have a look on the previous article which describes the LSA's in the OSPF network.

OSPF LSA's Quick Look

An OSPF type 5 LSA is originated by an Autonomous System Boundary Router (ASBR) and flooded within the OSPF area. These routes are generated by means of redistribution into OSPF from other protocols or by the redistribution of connected or static routes.

Here in our discussion, we are going to talk about the method to filter LSA type 5. Let's have a sample network topology.


Fig 1.1-Sample Topology OSPF-EIGRP
Configuration at San Jose Router
!
interface FastEthernet0/0
ip address 10.12.1.1 255.255.255.0
end
!
router ospf 1
network 10.12.1.1 0.0.0.0 area 0
!

Configuration at Toronto Router
!
interface FastEthernet0/0
ip address 10.12.1.2 255.255.255.0
end
!
interface FastEthernet1/0
ip address 10.23.1.1 255.255.255.0
end
!
router ospf 1
network 10.12.1.2 0.0.0.0 area 0
network 10.23.1.1 0.0.0.0 area 0
!

Configuration at Dubai Router
!
interface FastEthernet0/0
ip address 10.23.1.2 255.255.255.0
end
interface FastEthernet1/0
ip address 192.168.1.1 255.255.255.0
end
router ospf 1
network 10.23.1.2 0.0.0.0 area 0
router eigrp 1
network 192.168.1.1 0.0.0.0
no auto-summary
!

Configuration at Amritsar Router
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
end
interface Loopback100
ip address 172.16.1.1 255.255.255.255
end
router eigrp 1
network 172.16.1.1 0.0.0.0
network 192.168.1.2 0.0.0.0
no auto-summary

!

Above is the basic configuration on all the routers, now we will going to filter the LSA type 5 with the help of the distribute list

Configuration on ASBR router ( Dubai Router)-Distribute List
!
Standard IP access list 1
10 deny 192.168.1.0, wildcard bits 0.0.0.255
20 permit any
!
router ospf 1
redistribute eigrp 1 subnets
network 10.23.1.2 0.0.0.0 area 0
distribute-list 1 out eigrp 1
!

The summary-address command along with the not-advertise keyword can be used on the ASBR under the Router OSPF process to stop the propagation of a Type 5 LSA. On Dubai, the summary-address command has been used to stop the advertisement of the 172.16.1.0 Type 5LSA.

Configuration on ASBR router (Dubai Router)-Summary Address
!
router ospf 1
log-adjacency-changes
summary-address 172.16.1.0 255.255.255.0 not-advertise
redistribute eigrp 1 subnets
network 10.23.1.2 0.0.0.0 area 0
!

While redistributing an IGP into OSPF, a route-map can also be used to stop the TYPE 5 LSA from being generated on the ASBR. On Dubai, while redistributing from EIGRP, a route-map is used to deny the 192.168.1.0 subnet from being advertised into OSPF

Configuration on ASBR router (Dubai Router)-Route Map
!
Standard IP access list 1
10 deny   192.168.1.0, wildcard bits 0.0.0.255
20 permit any
route-map REDIS, permit, sequence 10
Match clauses:
ip address (access-lists): 1
Set clauses:
Policy routing matches: 0 packets, 0 bytes
router ospf 1
log-adjacency-changes
redistribute eigrp 1 subnets route-map REDIS
network 10.23.1.2 0.0.0.0 area 0
!


You can check now by using the command “show ip ospf database external” to confirm whether the LSAs that were filtered have indeed been blocked.

Popular Posts

Powered by Blogger.